Disappearing objects

2D CAD software for Windows, Mac OS X and Linux
Post Reply
debenriver
Posts: 479
Joined: Sat Dec 03, 2011 9:19 pm
Location: Maine USA and Suffolk England
Contact:

Disappearing objects

Post by debenriver » Mon Jan 14, 2019 3:50 pm

Hi Eric

If you draw a new object when a previous object is selected – like you might do when drawing a succession of (say) lines – then the selected object disappears until you have drawn the next object and released the mouse button, when it appears again. Same with text.

I think this only happened with 4.91b1??

Cheers -- George

Eric Pousse
Posts: 683
Joined: Sat Dec 03, 2011 12:31 pm
Location: Tours - France

Re: Disappearing objects

Post by Eric Pousse » Tue Jan 15, 2019 5:43 pm

Bonjour George,

I think that I saw this problem before and that I resolved it.
Now I can't reproduce it with 4.90 or 4.90b1... again, sorry.
Can you say if this appears also with 4.90?

Thank.
Eric Pousse

debenriver
Posts: 479
Joined: Sat Dec 03, 2011 9:19 pm
Location: Maine USA and Suffolk England
Contact:

Re: Disappearing objects

Post by debenriver » Fri Jan 18, 2019 3:52 pm

Hi Eric

With 4.90 there is no problem.

It only happens with 4.91b1 – see https://whisstock.com/disappearing.mov

Cheers -- George

Eric Pousse
Posts: 683
Joined: Sat Dec 03, 2011 12:31 pm
Location: Tours - France

Re: Disappearing objects

Post by Eric Pousse » Sat Jan 19, 2019 10:24 am

Bonjour George,

I can reproduced this bug with Mojave but not with High Sierra...

Thanks.
Eric Pousse

debenriver
Posts: 479
Joined: Sat Dec 03, 2011 9:19 pm
Location: Maine USA and Suffolk England
Contact:

Re: Disappearing objects

Post by debenriver » Sat Jan 19, 2019 2:47 pm

Good afternoon Eric

Ok - I've just two weeks ago changed my MacBook Air to a more modern one so I'm now on Mojave ...

I didn't think about that!!

But it still only happens with 4.91b1 - not with 4.90. 4.90 on Mojave is fine.

Cheers -- George

Eric Pousse
Posts: 683
Joined: Sat Dec 03, 2011 12:31 pm
Location: Tours - France

Re: Disappearing objects

Post by Eric Pousse » Mon Jan 21, 2019 9:18 am

Bonjour George,

Yes the bug does not occur with 4.90.
I think that it is because they are not compiled with the same version of Xojo...
Developers have to deal with their bugs but also with system changes and compilation changes.

But I think that it is OK now with RealCADD 4.91b2

Thanks.
Cordialement.
Eric Pousse

debenriver
Posts: 479
Joined: Sat Dec 03, 2011 9:19 pm
Location: Maine USA and Suffolk England
Contact:

Re: Disappearing objects

Post by debenriver » Mon Jan 21, 2019 11:01 pm

Good evening Eric

All seems fine now :mrgreen:

I used to do a lot of website design - don't do so much nowadays - same problem ... just keeping up with system changes, browser versions, IE nonsense, W3 development, et al: complete nightmare really :cry:

Many thanks - George

Post Reply